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i2b2 Table View

The Table View is designed to compile the requested data and display the information in a graphical
representation.
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Select Patients tab

The patients to be used when rendering tables in the Table View are defined in the Select Patients tab.
Patients can be added on an individual basis or by adding a group of pre-defined patients known as a Patient

Set or Patient List. In addition to adding patients, users can remove patients as well as change the order of the
patients.

Jewci Fater® | Select Concaomts | Aander Tsbhes

Owirts o List Detetn & Mowe Up | | Move Down

Figure 2.0 Select Patients tab

Layout of the Select Patients tab

Patient Set Information

Contains information about the patient set(s) used when creating the list of patients to be used when
rendering the tables.
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Sets Fatent Set Have

Figure 2.1 Patient Set Names

Field Name Description / Use

Set # Number assigned each set of patients as it is dragged and dropped into the Table View.
It is used as a reference point when viewing the patients in the patient list.

Patient Set Name The name filed in the database for the patient list/set that is being used.

Patient Information Section

Displays list of patients and the information that will be used when the tables are created.

ow # | Decson Phet # Fateret D Patert Name Gencer Race Owie of De e Age e

Figure 2.2 Patient information
Field Name Description / Use
Row # Identifies which row the patient will appear in when the tables are rendered.
Decision Field is currently not used. The only data that will appear at this time is UnD which means
Undefined.
PSet# Identifies which patient set the patient is part of. If the patient can be found in more than one

set then the set # for each patient set will be listed.



Patient ID Unique number for the patient. Used to identify the patient and their associated records.
Patient Name Name of the patient.
Gender Patient’s gender.
Race Patient’s race.
Date of Birth Patient’s date of birth. Date will appear as follows:
YYYYMMDDHHMMSS
Age Patient’s age
MRNs Medical Record Number(s) associated with the patient.
Add Patients

Patients can be added to the Table View by simply dragging the patient set from either the Previous Query
View or the Workplace View.

From Previous Query View

1. Expand the previous query that contains the set of patients that you want to add.
2. Click on the Patient List and drag the item over to the Table View.
3. Drop the patient list into the patient information section (figure 2.3).

L. Timeline View ] @ exportData 53 o =0

| (rme—
Select Patients | Select Concepts | Render Tables | '

Set = Patient Set Name

|~
[

Row # | Dedcision | PSet # | PatientID | Patient Name | Gender | Race | Date of Birth | Age | MRNs

| @

£
[ Delete From List ] [ Delete All ] [Move Up] [Move Down ]

[Select All v ‘




Figure 2.3 Adding a Patient

4. The patients included in the set will be listed along with the demographic information included in the PDO

(figure 2.4).
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Figure 2.4 Patient List

From Workplace View

Find the set of patients you want to use (either in your folder or a shared folder).
Click on the Patient Set and drag the item over to the Table View.
Drop the patient set into the patient information section (see figure 2.3).

P w N PRE

The patients included in the set will be listed along with the demographic information included in the PDO
(see figure 2.4).



Delete/Remove

There are three options for removing a patient from the list of patients to be used. Users can (1) delete the
entire listing of patients, (2) delete a single patient from the list, or (3) delete multiple patients from the list.

Delete All Patients

1. Click on the Delete All button located in the bottom of the view.
2. The list of patients will be cleared.

Warning: Once you click on the Delete All button, all the patients on the list will be removed, therefore you
need to make sure you want to delete everyone.

Delete Single Patient

1. Click on the patientin the list that you want to remove.
2. Once the patient is highlighted, click on the Delete From List button.
3. The patient will be removed from the list.

Delete Multiple Patients

Click on the first patient you want to remove.
Holding the Ctrl key down, click on the other patients in the list to be removed.
Click on the Delete From List button.

P wnNpe

Only those patients highlighted are removed from the list.

Move Patient

Each patient listed is assigned a Row # that is used when rendering the tables. This row # determines which
row the record (patient) will appear when the temporary table is created. Users have the option of moving
patients which will automatically update the row #.

Move Patient Up

1. Highlight the patient to be moved.
2. Click on the Move Up button.
3. Continue to click on the move up button until the record is in the desired location.

Move Patient Down

1. Highlight the patient to be moved.
2. Click on the Move Down button.



3. Continue to click on the move down button until the record is in the desired location.

Select Concepts tab

The concepts to be used when rendering tables in the Table View are defined in the Select Concepts tab. Users
can add individual or groups of concepts. In addition to adding concepts, users can define date and value
constraints for each concept

| Select Patients | Select Concepts | Render Tables

’ Row # I Name of Terms I Date Constraint Value Constraint
[ Delete From List ] | Delete Al | [ Put In Order ] [Move Up ] [Move Down ]
Figure 2.5 Select Concepts tab

Layout of the Select Concepts tab

Concept List

User defined list of concepts that will be used when the tables are created.



| Row #l Name of Terms Date Constraint Value Constraint

< | >
Figure 2.6 Concept list
Field Name Description / Use
Row # Identifies which row the concept will appear in when the tables are rendered.
Name of Terms The name of the concept
Date Constraint Limit the data to a user defined date range.

Note: If the field is empty then no constraints have been set.

Value Constraint Limit the data to a user defined range of values for a particular concept.
Not Applicable will appear if a concept can not have a value constraint set.

All Values will appear as the default if a concept can have a value constraint set.

Add Concepts

Concepts can be added to the Table View by simply dragging the concept from one of the following three
views.

1. Navigate Terms



2.

3.

(i @ e | ~ O

%8 €

@@ Clinical Trials

EIE Ontology
EEI@ Demographics
@
@ﬁ Expression Profiles Data
@@ Laboratory Tests
®-[3] Medications
El@ Procedures

Figure 2.7 Navigate Terms View

Find Terms

= i
@ revete e (i,

8 )

‘Search by Names | Search by Codes |

Acute Myocardial Infarction | ZJ|

|Containing ,vJ

[any Category ¥

m@ Acute myocardial infarction A

@@ Acute myocardial infarction, of anterolat g‘

----- D] Acute myocardial infarction, of anterolat
o B Acute myocardial infarction, of anterolat

------ B Acute myocardial infarction, of anterolat

@@ Acute myocardial infarction, of inferolate

------ ,@ Acute myocardial infarction, of inferolate

- B Acute myocardial infarction, of inferolate

-] Acute myocardial infarction, of inferolate ~
. i | B

Figure 2.8 Find Terms View

Workplace



Bhssa, © >~ 0

-5 SHARED
=] demo

% B Acute myocardial infarction, un:{
3l cardiac Tests

----- ﬁ Cardiovascular agents

{7 Ischemic heart @02:15:22 [01-

@ Ischemic heart disease

----- [# pATIENTSET 9028

£ |

Figure 2.9 Workplace View

From Navigate Terms View

1. Expand the folders that contain the concept or grouping of concepts that you want to add.
2. Click on the concept/term and drag the item over to the Table View.
3. Drop the concept into the section that displays the list of concepts (figure 2.10).

r 7 -
@ rneiee v (OSBRI a=-
Select Patients | Select Concepts | Render Tables |

Row #I Name of Terms | Date Constraint | Value Constraint

] i | B

[ Delete From List ] [ Delete Al | [ Put In Order ] [Move Up] [Move Down]




Figure 2.10 Dropping Concept

4. The concept will display (figure 2.11).

| Select Patients | Select Concepts |Render Tables |

Row # Name of Terms Date Constraint Value Constraint

1  Cardiovascular agents Not Applicable
< | >
[ Delete From List ] [ Delete All ] [ Put In Order ] [Move Up] [Move Down]

Figure 2.11 Concept List

From Find Terms View

1. After searching for the term(s) you want to add, click on the concept/term and drag the item over to the

Table View.
2. Drop the concept into the section that displays the list of concepts (see figure 2.10).

3. The concept will display (see figure 2.11).

From Workplace View

Find the set of concepts you want to add (either in your folder or a shared folder).
Click on the concept and drag it over to the Table View.
Drop the concept into the section that displays the list of concepts (see figure 2.10)

P w e

The concept will display (see figure 2.11).

Delete/Remove




There are three options for removing a concept from the list of concepts to be used. Users can (1) delete the
entire listing of concepts, (2) delete a single concept from the list, or (3) delete multiple concepts from the list.

Delete All Concepts

1. Click on the Delete All button located in the bottom of the view.
2. The list of concepts will be cleared.

Warning: Once you click on the Delete All button, all the concepts on the list and their constraints will be
removed, therefore you need to make sure you want to delete everyone.

Delete Single Concept

1. Click on the concept in the list that you want to remove.
2. Once the concept is highlighted, click on the Delete From List button.
3. The concept will be removed from the list.

Delete Multiple Concepts

Click on the first concept you want to remove.
Holding the Ctrl key down, click on the other concepts in the list to be removed.
Click on the Delete From List button.

P w N e

Only those concepts highlighted are removed from the list.

Move Concepts

Each item listed is assigned a Row # that is used when rendering the tables. This row # determines which row
the concept will appear when the temporary table is created. Users have the option of moving concepts to a
new row before the tables are created. The system will automatically update the row #.

Move Concept Up

1. Highlight the concept to be moved.
2. Click on the Move Up button.
3. Continue to click on the move up button until the record is in the desired location.

Move Concept Down

1. Highlight the concept to be moved.
2. Click on the Move Down button.



3. Continue to click on the move down button until the record is in the desired location.

Setting Constraints

There are two categories of constraints that can be defined in the Table View. One constraint is by the date
and the other is by the value associated to the constraint. Not all concepts have values. For instance, diagnosis
of Acute Myocardial Infarction does not have a value but the tests used to make the diagnosis do have values
(high, low, numeric, etc.).

Date Constraint

Users can define a date range to be used when compiling the data to be used when the tables are rendered.
This date range can be in any one of the following combinations:

SPECIFIED DATE RANGE: FROM AND TO DATES DEFINED
Only data with activity within the defined date range will be used.
Example:

Concept: Acute Myocardial Infarction
From date: 01/01/2001
To date: 12/31/2005

In this example, if a patient has a diagnosis of Acute Myocardial Infarction (Ml) entered on the record from
01/01/2001 to 12/31/2005 then their data will be included. If the patient does have an Ml diagnosis but it
was entered prior to 01/01/2001 or after 12/31/2005 then their information will not be included.

SPECIFIC START DATE: ONLY THE FROM DATE IS DEFINED
Data from the defined start date to the latest date available. No end date defined.
Example:

Concept: Acute Myocardial Infarction
From date: 01/01/2001
To date:

In this example, if a patient has a diagnosis of Acute Myocardial Infarction (Ml) entered on the record any
time on or after 01/01/2001 will be included. If the diagnosis was entered prior to 01/01/2001 then the
data will not be included.

SPECIFIC END DATE: ONLY THE TO DATE IS DEFINED
All data up until the defined end date. No start date defined.
Example:

Concept: Acute Myocardial Infarction
From date:
To date: 12/31/2005



In this example, if a patient has a diagnosis of Acute Myocardial Infarction (Ml) entered on the record prior
to and including 12/31/2005 then their data will be included. If the diagnosis was entered after
12/31/2005 then it will not be included.

SETTING THE DATE CONSTRAINT (FROM/TO DATE RANGE)

1.
2.

Double click on the field in the date constraint column.
A new window will open (Figure 2.12).

Constrain by dates

From: To:

[ |sat 12/01/1979 |

[ [wedotj21/2009 |

Figure 2.12 Date Constraint Window

3. Click the check box next to the date in the From box.

4. Highlight the default date and enter the date you want to use as your starting date (see figure 2.13).

Constrain by dates

From:

|01/01/2001 |

To:

[ [Thuoijzzizone |

Cancel

Figure 2.13

Date Constraint (From Field)




5. Click the check box next to the date in the To box.
6. Highlight the default date and enter the date you want to use as your ending date (Figure 2.14).

&

Z Choose time

Constrain by dates

From: To:

] |01/01/2001 | |12431/2005 |
L \

Figure 2.14 Date Constraint (From and To Fields)

7. Click on the OK button.

8. The date range entered will now appear in the date constraint column (Figure 2.15)

| Select Patients | Select Concepts | Render Tables |

Date Constraint Value Constraint

Acute myocardial infarcion  1/1/2001 -> 12/31/2005

<

camaraits] (s Erckcm ] i) epss]

fr—

Figure 2.15 Date Constraint (From/To Range)

SETTING THE DATE CONSTRAINT (FROM DATE ONLY)



Double click on the field in the date constraint column.

A new window will open (see figure 2.12).

Click the check box next to the date in the From box.

Highlight the default date and enter the date you want to use as your starting date (see figure 2.13).
Click on the OK button.

The date range entered will now appear in the date constraint column (Figure 2.16)

o vk wWwN R

Select Paents | Select Concepts | Render Tables

Row = Name of Terms Date Constraint Value Constraint

Aaste myocardal infarction

< >

| DeleteFromust || Deleteas || Putinorder | [Move up| [Move Down |

Figure 2.16 Date Constraint (From Date)

SETTING THE DATE CONSTRAINT (TO DATE ONLY)

Double click on the field in the date constraint column.

2. A new window will open (see figure 2.12).
3. Click the check box next to the date in the To box.
4. Highlight the default date and enter the date you want to use as your ending date (figure 2.17).

£ Choose time

Constrain by dates

From: To:

[ |sat 12/01/1979 | ‘ |12{31/2005 |




5.

Figure 2.17 Date Constraint (To Field)

Click on the OK button.

6. The date range entered will now appear in the date constraint column (figure 2.18)

Select Patients Select Concepts | Render Tables

Row = Name of Terms Date Constraint Value Constraint

1  Acute myocardial infarcbon -> 12/31/2005 Not Appicable
< >
| DeleteFromist || Deleteal || Putinorder | |Moveup | Move Down |

Figure 2.18 Date Constraint (To Date)

Value Constraint

As stated earlier, not all concepts have values. For those concepts that do can have values there are different
types of values that may be associated with it.

1.

Flag

Flags are defined in the source system when the value is entered. The following are some examples that
can be found in the i2b2 Demo database.

§ High

§ Low

§ Abnormal
Text

The text is defined in the source system when the value is entered. The following are some examples that
can be found in the i2b2 Demo database.

§ Test Not Performed

§ Borderline



§ Positive

3. Numeric

The numeric value is defined in the source system when the result is entered. The following are some
example formats that can be found in the i2b2 Demo database.

§ 200
§ 1.3

Unlike flag and text values, numeric values use operators, such as greater than or less than when setting
constraints for numerical values. The following is a listing of operators currently in use.

Operator Description/Use

Less Than (<) Any value less than the number entered.

Less Than or Equal To (<=) Any value less than or equal to the number entered (inclusive).
Equal To (=) An exact match to the number entered.

Between Any value in the range of numbers entered.

Greater Than (>) Any value greater than the number entered.

Greater Than or Equal To (>=) Any value greater than or equal to the number entered (inclusive).

SETTING THE VALUE CONSTRAINT (FLAG)

1. Double click on the field in the value constraint column.

2. A new window will open (figure 2.19).

£ Choose value

Searches by Lab values can be constrained by the highflow flag set

by the performing laboratory, or by the values themselves.
@ hio Value
() By highflow flag

By numeric value

units = | % v [ QK ][ Cancel ]




Figure 2.19 Value Constraint Window (Flag)

3. Click the radial dial next to By high/low flag.
4. Anew field with a drop down selection box will appear (figure 2.20).

£ Choose value

Searches by Lab values can be constrained by the highflow flag set
by the performing laboratory, or by the values themselves.

Mo Yal ?
LA Hioleke Please select range:
©Byhighflowfled [ 7 ] [HiaH v|
By numeric value

units = [ QK ][ Cancel ]

Figure 2.20 Value Constraint Flag

5. Click on the arrow to change the selection or accept the default.

6. Click on the OK button.
7. The constraint value entered will now appear in the value constraint column (figure 2.21)

| Select Patients | Select Concepts | Render Tables |

Row # Name of Terms Date Constraint Value Constraint

Troponin-I (Group:TROP-I)

| >

<

[ Delete From List ] [ Delete All ] [ Put In Order ] [Move Up] [Move Down]

Figure 2.21 Value Constraint Set (Flag)



SETTING THE VALUE CONSTRAINT (TEXT)

1. Double click on the field in the value constraint column.
2. A new window will open (figure 2.22).

£ Choose value

Searches by Lab values can be constrained by the abnormal flag

set by the performing laboratory, or by the values themselves.,

() By abnormal flag
() By text value

[] TEST NOT PERFORMED
] NP

[] BORDERLINE

[] POSITIVE

Figure 2.22 Value Constraint Window (Text)

3. Click the radial dial next to By text value.
4. The text value options will now become available to select. Click on the box next to the values you want to
include. (figure 2.23).



£ Choose value E]@

Searches by Lab values can be constrained by the abnormal flag
set by the performing laboratory, or by the values themselves.,
() No value

() By abnormal flag

(3) By text value

[] TEST NOT PERFORMED

] wp

[[] BORDERLINE

| @ [POSITIVE

Figure 2.23 Value Constraint Text

5. Click on the arrow to change the selection or accept the default.
6. Click on the OK button.
7. The constraint value entered will now appear in the value constraint column (figure 2.24)

| Select Patients | Select Concepts | Render Tables |

Row # Name of Terms Date Constraint Value Constraint

1 CK-MB QUANT (Group:CPK-MB) Is POSITIVE
< i | >
[ Delete From List ] [ Delete All ] [ Put In Order ] [Move Up ] [Move Down ]

Figure 2.24 Value Constraint Set (Text)



SETTING THE VALUE CONSTRAINT (NUMERIC)

1. Double click on the field in the value constraint column.

2. A new window will open (figure 2.25).

£ Choose value

Searches by Lab values can be constrained by the highflow flag set

by the performing laboratory, or by the values themselves.
@ hio Value
() By highflow flag
() By numeric value

units = D [ OK ][ Cancel ]

Figure 2.25 Value Constraint Window (Numeric)

3. Click the radial dial next to By numeric value.
4. Two new fields, one with a drop down selection box will appear (figure 2.26).

£ Choose value

Searches by Lab values can be constrained by the highflow flag set
by the performing laboratory, or by the values themselves.

O Mo Yalue Please select operator: ‘
v

[GREATER THAN ()
© By: highflow flag [;J Please enter value:
®Bynumericvalue [ 7 | \ 200] |

units = D [ OK ][ Cancel ]

Figure 2.26 Value Constraint (Numeric)

Click on the arrow to change the operator or accept the default.
Enter a numerical value at the Please enter value field.

Click on the OK button.
The constraint value entered will now appear in the value constraint column (figure 2.27)
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@ Timeline View . ExportData i3 | = 0O
Select Patients | Select Concepts erender Tables \
Row # Name of Terms Date Constraint Value Constraint
1 CPK (Group:CPK) > 200
< ‘ ¥
[ Delete From List ] [ Delete All ] [ Put In Order ] [Move Up] [Move Down]

Figure 2.27 Value Constraint Set Numeric

Render Tables Tab

The render tables tab (Figure 2.28) will use the information entered on the Select Patients and Select Concepts
tabs. In order to create the tables, information must be entered on these tabs. If data has not been entered, a

warning will appear (Figures 2.29 and 2.3.) and the user needs to go back to the appropriate tab and add the
required information.



Select Pabents | Select Concepts | Render Tabies |
Comping ol patents of type | UnD D

e [t Yew

= Tables
= [1) PatiertDomonraphics
oy, HEstogram of PatiertDemographics
A Hestograms of PatierDessogr aphics
2= Table of PatientDemogr aphics
W@ Hstogram3D of PatimetDamodr aphics
= [ Corcdovascudar agents
oy, Hstogram of Cardovasodar sgerks
A Hstograms of Cardhovasoular a0erks
52 Table of Cardovascular agents
& Histogram30 of Cardhovasculae agants
= [ Events
sk, Hetogram of Everts
A Hstograms of Events
&= Toble of Events
& Histogram3D of Events

Figure 2.28 Table View: Render Tables

L] L]
1 ) The patient table is empty. - | ) The concept table is empty.

Figure 2.29 Missing Patient(s) Warning Figure 2.30 Missing Concept(s) Warning

Creating Tables (Visualization)

As soon as the user clicks on the Render Tables tab, the system will begin compiling the data entered on the
Select Patients and Select Concepts tabs into tables. During the compilation process a message will appear in
the Render Tables tab view (Figure 2.31).



Working on visualization .......
Click on "select patients" tab to abort

Elapsed Time = 00 : 00
Estimated Time =00 : 10

Figure 2.31 Working on Visualization Message

Once the tables have been compiled the Control Panel with each of the tables and default views will display
(Figure 2.32.).

| Select Pabents | Select Concepts | Render Tabies |
Comping o patents of type  |UnD %

Be E&t Yew

A lERE s =@EsBEE

= Tables
= [ PatiertDomographics
oy, HEstogram of PatiertDemographcs
A Hetograms of PatierkDetsogr aphacs
22 Table of PatientDemogr aphics
W@ Hstogram3D of PatmetDemogr aphics
= [[) Cordovascular agents
oy, Hetogram of Cardovasoder sgents
A Hstograms of Cardhovascubar a0eeks
52 Table of Cardiovascular agents
& Histogram30 of Cardhovasauar agants
= [[) Events
sk, Hetogram of Everts
A Hstograms of Everts
5= Table of Events
& Histogram3D of Events



Figure 2.32 Render Tables: Control Panel

Cancel Rendering Tables

At any point during the rendering of the tables, the process can be cancelled by clicking on the either the
Select Patients or Select Concept tabs. Upon clicking on either tab, a dialog box will open asking if you want to
continue with the cancellation process (Figure 2.33).

Ca Please Note ... @

Changing this option will lose your work if it's not saved. Do you want to

-:{/ change?

Yes | [ No ]

Figure 2.33 Cancellation Dialog Box

Default Views
A set of four views will be created when the rendering process has completed.

Table
Histogram
Histograms
3D Graph

P w e

Common Charts

Histogram

A histogram typically shows the quantity of points that fall within various bins (or numeric ranges).

Pie Chart

A pie chart shows percentage values as a slice of a pie.

Line Chart



A line chart is a two-dimensional scatterplot of ordered observations where the observations are connected
following their order.

Control Panel

The control panel allows the user to import data tables to TableView, open various views on the data, and
save the selected rows of the data table.

Compiling all patients of type [U”D 8|

"Filéﬂ'i:&i’tﬁ(xi’ew
& B B
\ §§ 8 Ak il D 6 %&1 el

B Tables o)
—i . PatientDemoaqraphics =
=il Histogram of PatientDemographics

fr A Histograms of PatientDemographics
------ ‘_&' Table of PatientDemographics
@ Histogram3D of PatientDemoaraphics
=) Cardiovascular agents
- yh, Histogram of Cardiovascular agents
- A Histograms of Cardiovascular agents
§§ Table of Cardiovascular agents
ﬁ’ Histogram3D of Cardiovascular agents
=B . Events v |

Figure 2.34 Top level control panel

The panel consists of:

§ Menu bar

§ File/edit toolbar

§ View toolbar

§ Atree diagram of the open tables and views on those tables

Menu bar

The menu bar has three menu options.
File Importing and exporting data

Edit Options to edit a table or view



View Save the selected rows to a file

File Edit View

Figure 2.35 Menu bar

FILE MENU

The File menu on the main control panel provides choices for importing and exporting data.

Load table Load a table from a file, URL, or database
Save table Save the table to a file

Save selection Save the selected rows to a file

Output selection Feature is not currently available.

? Edit  View
load table ED

save table
save selection

output selection

Figure 2.36  File menu

Load Table

Import data from a file, URL or database to a new table.

Note: The load table feature can be accessed view the File Menu or by clicking on the load table icon ( &l )
located on the file and edit toolbar.

Load from File or URL

1. Select Load table from the File Menu or click on the icon on the toolbar.



2. The Load Table window will open (Figure 2.37).

Ca Load Table
File or URL | Database | Create Table | GenePix File | ClutoMatrix
File or URL:' browse ”

Field Separator: &) TaB (), Ol (O other:

| cancel l

Figure 2.37 Load Table

Across the top there are five tabs each representing the different methods to import the data.
Select File or URL tab.

Click on the Browse button (or manually enter the location of the file/URL)

A new window listing file locations will open. Locate and open your file.

The contents of the file will appear in the Load Table window.

©® N U AW

Next to the Load button there is a field labeled as: enter the table name as you want it to appear in Table

View.



9.
10. The new table leaf () will be created and appear on the main tree view.
11. To create a table view for this data, simply click on the Table icon (3;5) on the view toolbar or select Table

8 Load Table

File or URL [ Database | Create Table | GenePix File | ClutoMatrix
File or URL:[ browse J d Settingsijmd36\My Documentsitempiresearch_data\PatientDemographics.txt [ open ]
Field Separator: &) TAB (), Ol () other:

Patient I... Patient ID Birth Date Death Date = Race Gender Age InYe... DeathRe
izbz 1000000071|2023-06-30  |2005-06-09  |black F 83Y A~
izbz 1000000064 |1934-12-08 asian M 22N B
izbz 1000000087 (1955-01-26 asian M 52|N
izbz 1000000023(1976-11-04 hispanic M 30N
izbz 1000000034 |1935-05-08 black M 21N
izbz 1000000020(1958-09-15 black M 43|N
izbz 1000000132|1998-08-30 hispanic M 8N
izbz 1000000089(1965-12-23 black M 41N
izbz 1000000002 |1966-08-29 white F 40|N
izbz 1000000025(2033-10-06 hispanic F 73N
izbz 1000000119(2037-12-25 white F 69N
izbz 1000000005(1973-06-25 hispanic F 33N —
izbz 1000000010(1976-11-23 hispanic F 30N
izbz 1000000115(1997-07-25 black F alM
izbz 1000000042 (1979-09-14 black F 27N v

< | >

[ merge JBS:

3\My Documentsitempiresearch_data\PatientDemoagraphics.txt

into:

Figure 2.38

Load Table:

as: PatientDemographics_imported

File or URL

Click on Load to import the data into a new table.

View from the View menu.

Load from Database

o vk wN -

Select Load table from the File Menu or click on the icon on the toolbar.

The Load Table window will open (Figure 2.37)

cancel

Across the top there are five tabs each representing the different methods to import the data.
Select Database tab.

Click on the Edit Connections button
A new window Edit Database Account Preferences will open. Enter the appropriate information for your

database.



2 BhOMm M &4 &

Select Account: v

Account Name:

JDBC Driver: v
IDEC URL: v
Username: v
Password:

Figure 2.39 Edit Database Account Preferences

7. Click on the Connect button to connect to the database.

8. The database information will appear in the Load Table window.

9. Next tothe Load button there is a field labeled as: enter the table name as you want it to appear in Table
View.

@ Load Table
File or URL | Database | Create Table | GenePix File | ClutoMatrix

[ Edit Connections ] v

| connect I Mot connected to a database
< <
Catalogs’ Schemas’ Tables:. Imported Foreian Key Exported Foreign Key | Database Info |
Select Columns l Column Info JI

1 Primary Key !

ALY

Query [ Clear_]
< Ll >
Paging? [/] Rows: 100 2 Page: 1 [ subrmit ] stop

ALY

<>

Rows
- []Fit Columns [ ] Select Columns Copy

A ‘

merge as: into:

load as:

| cancel I



Figure 2.40 Load Table: Database

10. Click on Load to import the data into a new table.

11. The new table leaf () will be created and appear on the main tree view.

12. To create a table view for this data, simply click on the Table icon (qé) on the view toolbar or select Table
View from the View menu.

Load from Create a Table

Select Load table from the File Menu or click on the icon on the toolbar.

The Load Table window will open (Figure 2.37)

Across the top there are five tabs each representing the different methods to import the data.
Select Create a Table tab.

Click on the New Table icon (mz‘)
Using the toolbar, add the necessary columns and rows.
Manually enter the data into the table.
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Next to the Load button there is a field labeled as: enter the table name as you want it to appear in Table
View.

8 Load Table

File or URL | Database | Create Table | GenePix File | ClutoMatrix

[ [ﬁﬁ] [EU o H

| merge |as: ’ Table 2 into:
as: ‘ Table 2 :| cancel l




Figure 2.41 Load Table: Create a Table

9. Click on Load to import the data into a new table.
10. The new table leaf () will be created and appear on the main tree view.
11. To create a table view for this data, simply click on the Table icon (5_1_?;) on the view toolbar or select Table

View from the View menu.

Load from GenePix File

Select Load table from the File Menu or click on the icon on the toolbar.

The Load Table window will open (Figure 2.37)

Across the top there are five tabs each representing the different methods to import the data.
Select GenePix tab.

Click on the Browse button (or manually enter the location of the file/URL)

A new window listing file locations will open. Locate and open your file.

The contents of the file will appear in the Load Table window.

O N U A WDNPRE

Next to the Load button there is a field labeled as: enter the table name as you want it to appear in Table

View.

8 Load Table

' File or URL | Database | Create Tablerj GenePix File \'ClutoMatnx

File or URL:[ browse ]‘




Figure 2.42 Load Table: GenePix

9. Click on Load to import the data into a new table.

10. The new table leaf () will be created and appear on the main tree view.

11. To create a table view for this data, simply click on the Table icon (i?-::) on the view toolbar or select Table
View from the View menu.

Load from ClutoMatrix

Select Load table from the File Menu or click on the icon on the toolbar.

The Load Table window will open (Figure 2.37)

Across the top there are five tabs each representing the different methods to import the data.

Select ClutoMatrix tab.

Click on the Browse button (or manually enter the location of the file/URL) located next to the Matrix File
or URL: field.

A new window listing file locations will open. Locate and open your file.

v W e

The contents of the file will appear in the Load Table window.
Repeat these steps for the Row Label File or URL and the Column Label File or URL.

w e N O

Next to the Load button there is a field labeled as: enter the table name as you want it to appear in Table
View.



8 Load Table

' File or URL | Database | Create Table | GenePix Frirlre] ClutoMatrix

Matrix File or URL:[ browse ” [ open ]

Row Label File or URL:l browse ” “ open |

Column Label File or URL: [ browse ]l

cancel

Figure 2.43 Load Table: ClutoMatrix

10. Click on Load to import the data into a new table.

11. The new table leaf () will be created and appear on the main tree view.

12. To create a table view for this data, simply click on the Table icon (qé) on the view toolbar or select Table
View from the View menu.

Save Table

Save the data in a table to a tab delimited text file.

Note: The save table feature can be accessed via the File Menu or by clicking on the save table icon (%)
located on the file and edit toolbar.

1. Click on the table to be saved.
2. Go to the File Menu on the main Control Panel and select Save Table.
3. The save dialog box will open (Figure 2.44).
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Figure 2.44 Save Table

4. Select the location where the file will be saved.
5. At the File Name prompt enter a name for the file.

Note: Include the file extension in the file name.

Example: my_file_name.txt

6. Click on the Save button.

Save Selection

Save the selected data in a table to a file.

Note: The save selection feature can be accessed via the File Menu or by clicking on the save selection icon (

b=
E ) located on the file and edit toolbar.

1. Click onthe table to be saved.
2. Using <Ctrl>Left Mouse Button select the rows that contain the data to be saved. (Figure 2.45)
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Figure 2.45 Save Select Rows

Go to the File Menu on the main Control Panel and select Save Table.
The save dialog box will open (Figure 2.45).
Select the location where the file will be saved.

o vk~ w

At the File Name prompt enter a name for the file.

Note: Include the file extension in the file name.

Example: my_file_name.txt

7. Click on the Save button.

Output Selection

Currently this option is not available.



EDIT MENU

The Edit menu options apply the table or view which has focus in the tree display of the main control panel.

Table Columns Delete, reorder, or add columns to the table.
Set Default Mapping Order Determines the mapping order for character string columns.
Create Table from Selected Rows Create a new table of the selected rows from current table. The

new sub-table is added as a child view of the original table in
the tree diagram. The selections between this new sub-table and
the original will be linked.

Delete Item Delete this table or view and all other tables or views that
depend upon it.
JavaScript Window Formula interpreter: Rhino for JavaScript

Additional information can be found at
http://www.mozilla.org/rhino/

BeanShell Window Formula interpreter: BeanShell for Java

Additional information can be found at
http://www.beanshell.org/docs.html

File @ Yiew
: & Edit Table Columns

Set Default Mapping Order »
i Create Table from Selected Rows ;2
=% Delete item
=R
. JavaScript Window
BeanShell Window hic

L Hickaavarac ~F DatiantNarmaaranhi

Figure 2.46 Edit Menu

Edit Table Columns

Allows the user to change the name of the table, or add or remove columns from the table.

Note: The edit table column feature can be accessed via the Edit Menu or by clicking on the edit table columns
icon (UIH) located on the file and edit toolbar.
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Figure 2.47 Edit Table Columns

Add Column

A New Column dialog opens when choosing to insert or add a column. New columns can be columns from the
imported table, columns with user entered values, or formula columns that use a script to generate values.
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Figure 2.48 Add Column Dialog Box

Add Column After

N o vk wNnN

Highlight the column that will be in front of the new column.

Click on the Add Column Aftericon ([fj )

A new dialog box will open (see Figure 2.48)

Select the Data Type (see section on Data Types for more information).
Enter the additional information for the data type selected.

Enter the name for the new column.

Click on the Add button.

Add Column Before

N o vk wNnN

Highlight the column that will be after the new column.

Click on the Add Column Before icon (ﬁ] )

A new dialog box will open (see Figure 2.48)

Select the Data Type (see section on Data Types for more information).
Enter the additional information for the data type selected.

Enter the name for the new column.

Click on the Add button.

Delete Column

1.
2.
3.

Highlight the column to be deleted by clicking on the column header.
Click on the Delete Column icon (HIH)
The column will be deleted.



Data Type Options

There are several different data types available when adding a column to the table. When adding a column it is
necessary to define what type of data will be in the rows for that column.

Data Type Description

Table Column Selection of existing columns in the database.

Text String of characters in variable lengths.

Integer Whole numbers that can be positive, negative or zero. Contains no decimals, commas

or other symbols.
Number Numbers that contain decimals. They have a fixed precision and scale.

Date Date combined with a time of day. Time of day includes fractional seconds and is
based on a 24 hour clock.

Boolean Represents only two values: 0 and 1. Also known as a flag type in which the 0 and 1
are usually identified with false and true respectively.

BeanShell Formula interpreter: BeanShell for Java

Additional information can be found at http://www.beanshell.org/docs.html

JavaScript Formula interpreter: Rhino for JavaScript

Additional information can be found at http://www.mozilla.org/rhino/

FORMULA INTERPRETER: BEANSHELL FOR JAVA

Four variables are provided to the formula:

Variable Description

table the javax.swing.table.TableModel on which this formula operates
row the row of the cell in the table (row starts from 0)

col the column of the cell in the table (col starts from 0)

Cells the Cells class that has a number of useful static methods.

The formula should return a value.

To retrieve a value from a cell in the table, use the method from the TableModel interface:
table.getValueAt(row, col-1);


http://www.beanshell.org/docs.html
http://www.mozilla.org/rhino/

The Cells class provides a means to get a collection of table cells. (Cells uses java.util.Collection interface for
Java2, forJDK1.1 it uses java.util.Vector only.)

Cells class provides the following static methods:

Vector getValuesFrom(TableModel tableModel, int from_row, int from_col, int to_row, int to_col)
Return a list of cells from a rectangular portion of the table.
Object min(Collection cells)
Return the cell with minimum value of the cells in the list.
Object max(Collection cells)
Return the cell with maximum value of the cells in the list.
Object median(Collection cells)
Return the median value of all Number-typed cells in the list.
double sum(Collection cells)
Return the sum of all Number-typed cells in the list of cells.
double average(Collection cells)
Return the average mean value of all Number-typed cells in the list.
double variance(Collection cells)
Return the variance of all Number-typed cells in the list.
double stddev(Collection cells)
Return the standard deviation of all Number-typed cells in the list.
int count(Collection cells)
Return the count of cells in the list.
int count(Collection cells, Object obj)
Return the number of times the given obj appears among the cells in the list.
int count(Collection cells, Class javaClass)
Return the number of cells in the list are of the given java class.
Set distinct(Collection cells)
Return the set of distinct cells in the list with duplicates removed.
List sort(Collection cells)
Sort the cells in place.
List reverse(Collection cells)
Reverse the order of the cells in place.
List fill(Collection cells, Object obj)
Fill the list with the given obj.
List getCommonClasses(Collection collection)
Return a list of java Classes that all cells in the list belong to.
Class getCommonClass(Collection collection)
Return the most specific java Class that all cells in the list belong to.
Set getCommonlnterfaces(Collection collection)
Return a list of java interfaces that all cells in the list implement.

BeanShell Example formulas:




Example 1

// return column 1 - column 0
table.getValueAt(row, 1) - table.getValueAt(row, 0);

Example 2

// return the previous column value with a maximum number of decimal places
double dp = 100; // set number of decimal places

Object v = table.getValueAt(row,col-1);

return v instanceof Number ? Math.round(((Number)v).doubleValue() * dp) / dp : null;

Example 3

// return the sin of column 0
Math.sin(((Number)(table.getValueAt(row,0) + 1.)).doubleValue());

Example 4

// average the values in a range of rows
Cells.average(Cells.getValuesFrom(table,row-1,col-1,row+1,col-1));

Example 5

// return the sum of the preceeding columns
double sum =0,;
for (int c = 0; c < col; c++) {

Object v = table.getValueAt(row,c);

if (v instanceof Number) {

sum += ((Number)v).doubleValue();

}

}

return sum;

Set Default Mapping Oder

Determines the mapping order for character string columns.

§ Natural Order
§ AlphaNumeric Order
§ Table Row Order

Create Table from Selected Rows

This creates a sub-table that contains only the selected rows from the selected parent table. The sub-table
references rows in the parent table, and thus will reflect any changes made to that table. Row selection is also



linked between the tables, so that any selection of rows in one table will be reflected in the other.

Note: The create table from selected rows feature can be accessed view the Edit Menu or by clicking on the

‘.
sub-table icon (E ) located on the file and edit toolbar.

1. Click on the table containing the data you want to use to create a new table.
2. Using <Ctri>Left Mouse Button select the rows that contain the data to be saved. (Figure 2.49)

£ Table of Cardiovascular agents
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Figure 2.49 Save Selected Rows

3. Go to the Edit Menu on the main Control Panel and select Create Table from Selected Rows.
4. The new table leaf () will be created and appear on the main tree view. (Figure 2.50).
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Figure 2.50 Branch pre- and post-creation of new table from selected rows

5. To create a table view for this data, simply click on the Table icon (-* ) on the view toolbar or select Table
View from the View menu.

Delete Item

Delete this table or view and all other tables or views that depend upon it.

.....

Note: The delete item feature can be accessed view the Edit Menu or by clicking on the delete item icon (ﬁ!‘)
located on the file and edit toolbar.

1. Click on the view to be deleted.

2. Go to the Edit Menu on the main Control Panel and select Delete Item.
3. Theitem will be deleted.

Warning: Once you click on the Delete Item it will be removed, therefore you need to make sure you have
selected the correct view.

Java Script Window

A new window opens allowing the user to write code using a formula interpreter (Rhino for JavaScript).
Additional information can be found at http://www.mozilla.org/rhino/

Beanshell window

A new window opens allowing the user to write code using a formula interpreter (BeanShell for Java).
Additional information can be found at http://www.beanshell.org/docs.html

VIEW MENU

The views in the Table View are distinguished from other i2b2 Workbench views by their ability to show the
information in a graphical representation.


http://www.mozilla.org/rhino/
http://www.beanshell.org/docs.html

Views can be opened on the selected table either from the View menu or the view toolbar.
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Navigation in Views

Zoom In/Out (Axis Displays on Views)

The Axes displays on several of the views allow the user to zoom in, zoom out, pan across, or pan up and down
the view of the data by using the mouse or the arrow keys.

Note: Note all axes have the ability to zoom.

Z00OM IN
Keyboard: Press the UP arrow key.

Mouse: Use Left Mouse Button to zoom in on the view. The point at which the button is pressed will move to
the left edge, and the point at which the button is released will move to the right edge.
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ZOOM OUT

Keyboard: Press the DOWN arrow key.

Mouse: Use <Ctrl>Left Mouse Button to zoom out on the view. The left edge will move to the point at which
the button is pressed, and right edge will move to the point at which the button is released.
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PAN ACROSS

Zoom Out - Y Axis

fge ]

55

50

45 ]
40
35

30

Keyboard: Press the LEFT arrow or the RIGHT arrow key.

Mouse: Using <Shift>Left Mouse Button to pan across the view: press the button and drag to pan.
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Figure 2.57 Pan Across - X Axis

PAN UP & DOWN

Keyboard: Not available.

Mouse: Using <Shift>Left Mouse Button to pan up and down the view: press the button and drag to pan.
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Figure 2.58 Pan Up and Down - Y Axis

Save Images

All views can be saved to an image.

1. Open the view to be saved.
2. Click on Save Image located at the top of the view.
3. The save dialog box will open (see Figure 2.59)
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Figure 2.59 Save Images

4. Select the location of where the image will be saved.
5. Select the image format that is appropriate for your use.
6. If necessary, change the default image size.
7. Enter the file name for the image.
8. Click on the Save button.
Save PDF

All views can be saved to a PDF.

1. Open the view to be saved.
2. Click on Save PDF located at the top of the view.
3. The save dialog box will open (see Figure 2.60)
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Figure 2.60 Save PDF

4. Select the location of where the image will be saved.



5. If necessary, change the default PDF size.
6. Enter the file name for the PDF.
7. Click on the Save button.

Views

Table View ( &)

A table (-oig) shows a column for each attribute and one or more rows of data. It provides a view of the data as

a table which is similar to a traditional spreadsheet.

The small bar along the left margin shows the location of selected rows within the entire length of the table. A

mouse click in this area will scroll the table to that location.

The left margin of the table shows the row number indices of the table in its original sort order.

£ Table of Cardiovascular agents
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TABLE VIEW FEATURES

The table view has features for refining the display to suit your needs.

Column Descriptions

Descriptions of the attributes for which data is reported are displayed.

Column Adjustments
You can make the following adjustments to columns:
Adjust column width by dragging a border left or right.
Change a column order by dragging a column heading and dropping to insert it between two columns.

Column sort is done by clicking on the up or down arrow in the column heading. To return to the original sort
order, click on the appropriate arrow in the row # column.

Up Arrow — ascending order
Down Arrow — descending order
Additional Sorting criteria — hold the <Shift> key while clicking on other arrows.

Remove Additional Sorting — hold the <Ctrl> key while clicking on an arrow.

Fit Column will force the table to fit the width of the window by either expanding or shrinking the column
widths.

Select Columns allows the user to select one or many columns.

Copy

The Copy button copies the text values of the selected cells in the table to the system clipboard. The values can
then be pasted in other applications.

Adding a Table

Note: The add table feature can be accessed via the View Menu or by clicking on the table icon (i?’?) located on
the file and edit toolbar.

1. Onthe main Tree View highlight the branch, also referred to as table leaf () in which the new tableis to
be created (Figure 2.62)
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Figure 2.62 Add Table: Highlight branch/leaf

2. Click on the Table icon (qg) on the view toolbar or select Table View from the View menu.
3. Anew table will be created and appear under the selected branch (Figure 2.63).
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Figure 2.63 Add Table

EDITING A TABLE

For information on editing a table please see Table Columns section of the help.

SAVING A TABLE

For information on saving a table please see Save Table section of the help.

REMOVING A TABLE

For information on removing a table please see Delete Item section of the help.

Cluster Rows ( = )

Cluster Rows performs a hierarchical clustering of the rows of the table based on the values in the selected
columns. The distances between rows can be calculated using a variety of distance functions available in the
CERN colt package. The default is Euclidean distance. The distance calculation between clusters can be set to
Average (the averages of the rows distances between the cluster), Single-link (the least row distance), or
Complete-link (the greatest row distance). The cluster button starts the clustering process.



The hierarchical cluster is displayed as a dendogram. Dragging out an area over the dendogram selects all rows
in the table represented by the branches of the tree in the selected area.
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Figure 2.64 Cluster Rows

Cluto Cluster ( ﬂ)

CLUTO is a 3™ party software package for clustering low- and high-dimensional datasets and for analyzing
characteristics of the various clusters.
ALGORITHMS

CLUTO provides three different classes of clustering algorithms that operate either directly in the object's
feature space or in the object's similarity space. These algorithms are based on the partitional, agglomerative,
and graph-partitioning paradigms.

A key feature in most of CLUTO's clustering algorithms is that they treat the clustering problem as an
optimization process which seeks to maximize or minimize a particular clustering criterion function defined
either globally or locally over the entire clustering solution space.

Criterion Functions

CLUTO provides a total of seven different criterion functions that can be used to drive both partitional and
agglomerative clustering algorithms. Most of these criterion functions have been shown to produce high
quality clustering solutions in high dimensional datasets, especially those arising in document clustering.

Multiple similarity/distance functions:
§ Euclidean distance
Cosine

Correlation coefficient

w L WL»n

Extended Jaccard



§ User-defined

Traditional agglomerative merging schemes:

§ Single-link
§ Complete-link
§ UPGMA

Graph-Partioning-based clustering algorithms

Furthermore, CLUTO provides graph-partitioning-based clustering algorithms that are well-suited for finding
clusters that form contiguous regions that span different dimensions of the underlying feature space

ADDITIONAL FEATURES

Multiple methods for effectively summarizing the clusters: most descriptive and discriminating dimensions,
cliques, and frequent itemsets.

Can scale to very large datasets containing; hundreds of thousands of objects and tens of thousands of
dimensions.
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Compare Columns ( 3 )
Shows a line graph of the values of each selected column, superimposed using a common scale.

This might be a useful view of the table if successive rows in the table represent a time series of values
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Figure 2.66 Compare Columns

Compare Rows (Parallel Coordinate) ( )

This view displays the values of each row of a table as a line graph across a set of vertical axes which represent
the columns of the table. Each vertical axis line represents one column from the table and each value from that
column to map to the line by its relative distance between the minimum and maximum value for that column.

The user may select rows from the table by pressing the mouse button over a vertical axis and dragging
vertically to select a region of values in that column.

The Selection of columns to operate on is controlled by selecting the diamond shape for the column at top the
graph. The selection status of the column is indicated by whether the diamond-shape if filled. The anchor
selection is drawn in black. Clicking on a diamond will select that column, a Double-Click selects only that
column, and a Control-Click toggles the selected status of the column.

The Toolbar buttons operate as follows:

§ Show All causes all columns to be displayed.
Hide will hide the currently selected columns from view.

Group will set the display range the same on the currently selected columns.

w L Wn

Normalize will set the display range independently for each selected column.

The Radio buttons control which rows are displayed:



§ All Rows Display all rows from the table.
§ Selected Rows Tracks the selection and display those rows from the table.
§  Current Rows Locks the display on the current selection.

The color gradient of the graph lines can be set to a column by double-clicking the diamond shape for the
column at top the graph.

The columns may be reordered by dragging the diamond shape above a column to the left or right.

The mapping order of a column may be inverted by clicking on the triangle below the column.
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Figure 2.67 Compare Rows

Graph Columns ( iﬁ)

Shows a line graph of the values in a column across all the rows in the table. A graph can be slid up or down by
dragging the label with the mouse. This allows separate line graphs to be superimposed. Note that each line
graph is normalized to its own value range, so superimposed graphs do not share a common scale.

This might be a useful view of the table if successive rows in the table represent a time series of values.

The user may select rows in the table by pressing the mouse button over a graph and dragging left or right to
select a region on the graph.
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Figure 2.68 Graph Columns

Histogram ( ln )

This view presents a bar chart to represent the histogram. If multiple columns are included in the histogram,
this will be a grouped bar chart.
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Figure 2.69 Histogram



HISTOGRAM EDITOR

A histogram divides the range of a set of values into a number of bins, and reports the number of values that
fall into each bin.

The Histogram Editor defines the bins for each of the table columns included in the histogram.

Pﬁ]

Concept Name 13 values (9 distinct) from Accuped 20mg tablet Parke-Davis to Nitroglycerin 2% ointment Fougera
Divide Range | Distinct Values | Categorize by Pattern

Set the Number of Bins 9

Figure 2.70 Histogram Editor Dialog Box

Histograms ( 4 )

This view presents a histogram for each column in the table. A histogram shows how many rows of the table
have values that fall in each sub range between the minimum and maximum values for a column. Changing the
width of the window will cause each histogram to be recomputed.

The toolbar has a button with an iconic histogram for each column in the table. Selecting a button on the
toolbar displays an interactive histogram.

The user may select rows from the table by pressing the mouse button over a histogram and dragging left or
right to select a range of values from the column. Rows from the table that correspond to that range of values
are selected.

The highlighted portion of each bar shows how many rows with that value are selected.
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Figure 2.71 Histograms

Histogram 3D ( )

This view presents 3 dimensional bars to represent a histogram calculated over 2 table columns.
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Figure 2.72 Histogram 3D

Java 3D ( ﬂ)
Scatter Plotsin 3D
Provides a 3D scatter plot of values from three columns of a table.
The Java3D component provides high performance 3D viewing.

The Plot 3D component is an all software version that provides similar functionality for those that don't have
Java3D.

A control button sets interaction to either navigation or selection. While navigating the left mouse button
rotates, the center mouse (or Alt Left Mouse Button) zooms in or out, and the right mouse button translates
the view up, down, left or right. While selecting, press the mouse over the view and drag out a region to select
rows corresponding to the values in the selected region.
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Figure 2.73 Java 3D

Pie Chart ( ¥ )

This view presents a pie chart to represent the histogram. If multiple columns are included in the
histogram, there will be a ring for each column.
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Figure 2.74 Pie Chart

Plot 3D ( # )
Scatter Plots in 3D
Provides a 3D scatter plot of values from three columns of a table.
The Java3D component provides high performance 3D viewing.

The Plot 3D component is an all software version that provides similar functionality for those that don't have
Java3D.

A control button sets interaction to either navigation or selection. While navigating the left mouse button
rotates, the center mouse (or Alt Left Mouse Button) zooms in or out, and the right mouse button translates
the view up, down, left or right. While selecting, press the mouse over the view and drag out a region to select
rows corresponding to the values in the selected region.
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Figure 2.75 Plot 3D

Row Graphs ( @)

This displays a table that has a row for each distinct value of the selected column. The table displays the value
in the first column and a graph of row values in the second column. Double-Clicking on the graph, will open a
Compare Rows view.

The column to display is selected in the Graph Column box.

The height in pixels for each graph can be set in the Graph Height box. The width of the graph can be adjusted
by dragging the edge of the column header.

The look of the graph is set using the Graph Prototype. This is a Compare Rows view that serves as a model
for all of the graphs displayed.
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Figure 2.76 Row Graphs
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Figure 2.77 Graph Prototype

Scatter Plot ( # )

This provides a pairwise scatter plot of any two columns in the table. The columns are selected by choosing
from the X and Y lists of column names, and the scatter plot is displayed when the Plot button is pressed.

The user may select rows from the table by pressing the mouse button over a scatterplot and dragging out a
rectangular region.
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Figure 2.78 Scatter Plot

Scatter Plot Icons ( )

This provides a pairwise scatter plot of any two columns in the table. A thumbnail icon is generated for each
pair of columns in the table. Clicking an icon open an interactive Scatter Plot view for that pair of columns.
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Figure 2.79 Scatter Plot Icons

Span Plot ( =)

This provides a pairwise scatter plot of any three columns in the table. Two columns represent the starting and
ending values of a span along the X axis, while the third column provides the mapping to the Y axis. The
columns are selected by choosing from the Xs, Xe, and Y lists of column names, and the span plot is displayed
when the Plot button is pressed.

The user may select rows from the table by pressing the mouse button over a scatterplot and dragging out a
rectangular region.
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Figure 2.80 Span Plot

Select by Regular Expression Mapping ( 8 )

Search allows for the search of matching values in a column. Enter a regular expression for the desired column,
and then press the Set operation to specify how to apply the matches to the selection of rows. Example:

Match values that contain 'nitroglycerin’ * nitroglycerin.*

Match values that start with 'nitroglycerin' . _—
nitroglycerin.

Match values that end with 'nitroglycerin’ *, nitroglycerin

Selection Set Operation Choice:



Replace ( #) Replace the previous selection with new selection
Union ( &) Union previous selection with the new selection
Intersect (&%) Intersect previous selection with the new selection
Diff ( (I ) Delete the new selection from the previous selection

XOR ( &8) Exclusive OR of previous selection with new selection

For more information on regular expressions:

http://java.sun.com/docs/books/tutorial/extra/regex/index.html
http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html

£ Select by Regular Expression Matching of Cardiovascular agents Q@@

. Close Save Image Save PDF

b

(@]

Column Regular Expression Replace Union Intersect R

Patient id Source
Patient id
Concept Name .nitroglycerin,*
Start Date

End Date
Modifier Name
Value Type Code

Observer Name
Event id Source
Event id

Path

SEEEEEEEEEEEEEEEs
BEEEaEEsssssEEEss

laltatctctetetoto o tatatadadah

BEEBEBEEEEBEEEEES

Figure 2.81 Select Regular Expression Mapping
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